Apache Sentry任意代码执行漏洞(CVE-2016-0760)

Apache Sentry任意代码执行漏洞(CVE-2016-0760)

发布日期:2016-08-12
更新日期:2016-08-22

受影响系统:

Apache Group Hive < 1.7.0

描述:


BUGTRAQ  ID: 92328
CVE(CAN) ID: CVE-2016-0760

Apache Hive是数据库软件,有利于查询和管理分布式存储设备上大型数据集。

Apache Sentry < 1.7.0版本存在多个不完整黑名单漏洞。远程用户通过reflect、reflect2、java_method Hive内置函数,利用此漏洞可执行任意代码。

<*来源:Ryan Pridgeon
  *>

建议:


厂商补丁:

Apache Group
------------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://mail-archives.apache.org/mod_mbox/sentry-dev/201608.mbox/%3CCACMN7ixDqDyOZGLEvsMUVHBiJ6crq8zdy%2B2mNfRooNhnk7CJ1g%40mail.gmail.com%3E

参与评论